
 Introduction

The Pattern Wizard software helps you to draw stained glass patterns.

With the Pattern Wizard you can draw a pattern, color its pieces with real glass, print a full size 
template or a one-page color picture, and print a shopping list of the quantities glass you'll need 
to build your design.



 How Drawing Works

In the Pattern Wizard, you draw your pattern as a web of connected lines.

Straight lines are defined by the points at each end. A curve has at least three points and you 
control its shape by moving the points along its length.

When you move one point onto another, they merge and that's how you join lines.

If you move a point near a line, but not near any of the line's points, that moved point will turn 
yellow and stick to the line. When the line moves or changes shape, that yellow point will move 
with it. This lets you join lines without having to insert needless points. 

To keep your design as easy to maintain as possible, you should try to minimize the number of 
points in your pattern. You should also try to use yellow points wherever convenient.

A pattern piece is formed by a closed set of lines. The Pattern Wizard can't recognize a piece if 
there are gaps between points, no matter how small, or if lines cross without a point at the 
intersection. Choosing Find Problems from the View menu will help you to find most things that 
could confuse the Pattern Wizard.

You should also see the page on selecting and manipulating parts of your pattern.

And please remember to save often.



 The Drawing Area

The drawing area for each pattern is endless. You don't need to specify a pattern size. You can 
simply draw wherever you like and the Pattern Wizard will take care of placing the design when 
you print.

Though you can draw anywhere, the rulers are more helpful when a corner of your design or its 
center is at the center of the drawing area.

The visible part of the drawing area is the white rectangle bordered by the rulers and the scroll 
bars. You can control what part of the drawing area is visible by zooming and panning.



 Tutorial

This explains how to design a simple pattern of a bordered flower in the Pattern Wizard.

Prepare the Grid

Since our design has many horizontal lines, vertical lines, and right angles, we should set up the 
grid. You can control the size of the grid squares and it's usually best to make them as small as 
possible while still being able to see them when you have the whole pattern visible. In our case, 
1" squares will work well.

To set that choose Set Grid Dimensions from the View menu.

Now make sure the grid  and snap  toolbar buttons are depressed. The grid button makes 
the grid visible. The "snap" button forces points to be on the corners of the grid after you move 
them.

Prepare to Start Drawing

The pattern will be 16" wide and 20" tall. You should zoom and pan until an area of that size is 
visible (according to the rulers) and until 0" on both rulers is near the upper left corner.

We will exploit the symmetries in the pattern by only drawing a quarter of it and then using copy 
& paste and mirror & flip to make the rest.

Draw the Upper Left Quarter of the Border

If you make any mistakes along the way, click on undo  in the toolbar.

To explain exactly where you should draw I will specify positions in coordinate form. 0",0" for 
example. The number before the comma is the position in inches along the horizontal ruler. The 
number after the comma is the position along the vertical ruler. You can also know exactly where 
your mouse is in the drawing by looking at the coordinates at the bottom left corner of the Pattern 
Wizard.

To start drawing straight lines, click on the line  tool in the toolbar. You start a line by left 
clicking. You end it by double clicking.

Now draw the two outside lines of the border from 0",0" to 8",0" and 0",0" to 0",10". As you draw, 
the exact location of your mouse and the length of the line being drawn are shown in the status 
bar at the bottom of the Pattern Wizard. Draw the two interior lines from 0",1" to 8",1" and 1",0" 
to 1",10".

Since the next few steps involve only this quarter of the pattern, zooming in could be helpful. 
Even easier, press the space bar button.



Draw the Upper Left Quarter of the Flower

Choose the ellipse/circle  tool. Left click at 8",10". Hold down the Control key to make a circle 
instead of an ellipse. Move the mouse until the circle is two inches wide (watch the status bar), 
and then left-click again. Now you can release the Control key.

Now we can draw the leaves. Choose the curve  tool. Click on the left-most point of the circle 
(7",10"). Click again at 5",9" and double-click at 1",10". Click at the top-most point of the circle 
(8",9"); click again at 7",6" and double-click at 8",1".

Now you can draw the petals, but first you should turn off snap by clicking on . Choose the 

arc  tool. Draw from somewhere on the right half of the left leaf to 6",8", ending somewhere 
on the lower half of the top leaf.

You might want to move some of the leaves' and petals' points around until you're happy with 
their shape.



Mirror Mirror

You should turn snap back on now. Choose the selection  tool. Move the mouse above and to 
the left of all you've drawn, press and hold down the left mouse button, drag the mouse below and 
to the right of the pattern, and then let go of the left mouse button.

You can copy all you've selected to the clipboard by choosing Copy from the Edit menu. Now 
choose Paste from the Edit menu. First, move what you've pasted aside by left clicking and 
dragging on any of the lines or points of what you just pasted. Make sure to move it far enough 
that it doesn't overlap with what you copied, otherwise they might get stuck together.

Now choose Mirror from the Change menu. To put the two pieces together, you just have to 
select one half and move it into place.

To finish the design, just copy and paste it again. The only difference this time is that you should 
choose Flip from the Change menu.

As an afterthought, you could add lines halfway along each side of the border.

To make sure you'll be able to color your pattern's pieces, you should run Find Problems from 
the Edit menu. It should ask you to insert points where lines cross. You do that by choosing the 

add point  tool and then clicking on a line or curve where you want a point to be inserted.





 Answers to Common Questions

How do I resize a pattern?

Choose Select All from the Edit menu. Then choose Size from the Change menu.

How do I get the list of quantities of glass needed to build a design?

Choose Pattern Statistics from the Edit Menu.

Why is the Pattern Wizard so slow?

If you're using the glass view (see the View menu), your design may be too complex to quickly 
update. Try editing while in the draft or colored view.

You should also make sure you're display is in 24 or 32 bit color. To check that, right click on the 
Windows desktop, choose Properties, and click on the Settings tab.

Why can't I fill a glass piece?

Some lines may not be meeting properly, or lines might be crossing without there being a point at 
the intersection. Try Find Problems in the Edit menu. Sometimes you might also need to zoom in 
closely to see a flaw.

Can the Pattern Wizard work in metric?

Sorry, not yet.



 Tips

Save often!

Try to fill glass pieces only after you're finished drawing because design changes can cause 
some pieces' color to be lost.

When you make a mistake and want to return something to where it was, use undo  instead of 
trying to manually move it back.

You can quickly change tools using the function keys: F2 to F10.



 Menus

For more information on a menu item, move your mouse over it and look at the status bar.



 Toolbar

The row of buttons near the top of the Pattern Wizard is the toolbar. Its buttons provide access to 
the drawing tools and to frequently used commands.

On the left are the standard file, clipboard, and undo buttons. Next are the tools and grid & snap.

 controls whether points appear. Hiding the points lets you see your pattern more clearly.

 toggles the selection box.

 toggles a background picture.

To get a reminder of what any button does, hold your mouse over it.



 Palette

The column of buttons on your right is the palette. Each button can hold a kind of glass. 

Click on one of the palette buttons and then click inside a pattern piece to fill it with that glass. 
Make sure you're viewing the design at least in color, otherwise you won't see a change.

To change the kind of glass in a palette button, double click on it.

To get a kind of glass from a pattern piece to the palette, click on a palette button and then right 
click inside a piece.



 Rulers

The rulers at the top and left of the drawing area are there to indicate the size that the parts of 
your design will print at.

It doesn't really matter where your design is relative to 0",0" on the rulers.



 Status Bar

The row at the bottom of the Pattern Wizard is the status bar. At its left is the exact location of the 
mouse in the drawing area.

When you have your mouse over a menu item, the status bar will usually tell you more about 
what that item does.

While drawing, the status bar will often provide size information.



 Context Menu

You can expose the context menu by selecting part of your design and clicking the right mouse 
button while inside the drawing area. The context menu provides convenient access to many 
commands.



 Grid and Snap

If your pattern will have any horizontal lines, vertical lines, or right angles, you should set up the 
grid. You can control the size of the grid squares and it's usually best to make them as small as 
possible while still being able to see them when you have the whole pattern visible.

To set the size of the grid's squares choose Set Grid Dimensions from the View menu.

The grid is visible if  is depressed in the toolbar.

The snap  toolbar button forces points to be on the corners of the grid after you move them.



 Selection Box

When  is depressed in the toolbar, the selection box appears around anything you've 
selected. The selection box lets you easily resize or rotate the selection by hand.

While resizing with the selection box, hold down the Control key to resize proportionately. Hold 
down the Shift key to resize around the selection's center



 Views

The top of the View menu offers three ways to see your pattern: draft, colored, and glass view. In 
draft mode you only see your pattern's lines. In colored mode the pieces are filled with solid 
colors. In glass mode your pattern's pieces are shown as realistically as possible.

Glass view can get slow, so initially you might want to work in draft or colored mode.



 Pan

You can pan the visible area of your design using the scroll bars or the arrow keys.



 Select

Use the select  tool to change the parts of your pattern. When a point or a line is selected, it 
turns red. 

When using the selection tool ...

Left click and drag a point or line to move it.

Click on anything and press the delete key to erase it.

Left click over empty space and then drag to select a group of things.

Hold down the shift key to select multiple things.

Double click inside a pattern pieces to change its color.

Select something and then use the Change menu to transform it.

Double click on part of a curve to select the whole chain at once.

To unselect, press the Escape key or click outside your pattern.



 Zoom

Using the zoom  tool you can zoom in and out on your design. Left click in the drawing area 
to zoom in. Right click to zoom out.

You can also zoom at any time using the + and - keys.



 Insert Point

Use the insert point  tool to add points along the length of a line or curve.

You usually shouldn't use this on circles or arcs.



 Detach Line

Use the detach  tool to pull a line away from a point.



 Line

 This tool is for drawing straight lines.

You start a line by left clicking. You can make a chain of lines by left clicking repeatedly.

To finish a line, double click.

To cancel a line, right click.



 Square

 This tool is for drawing squares and rectangles.

You click once to start a rectangle, and once again to complete it.

To make a square, hold down the Control key while drawing.



 Circle

 This tool is for drawing circles and ellipses.

You click once to start an ellipse, and once again to complete it.

To make a circle, hold down the Control key while drawin



 Arc

 This tool is for drawing circular arcs.

You start an arc by left clicking. Click again to continue it. Double click to close it.

I don't recommend drawing arcs with more than three points. They can be problematic 
mathematically.

Unless you definitely want an arc shape, you should use the curve tool.



 Curve

 This tool is for drawing curves.

You start a curve by left clicking. You can make a chain of curves by left clicking repeatedly.

To finish a curve, double click.

To cancel part of a curve, right click.



 Copy and Paste

You can copy and paste parts of your pattern using the  and  toolbar buttons. When you 
paste you should move what has been created straight into place or away from your pattern. If 
you move it around over other parts of your pattern, they can become tangled.



 Printing

To print your pattern to its true size, choose Print Pattern from the File menu. The Pattern 
Wizard should automatically choose the most efficient page orientation.

To print a one page copy of your pattern, choose Print Picture from the File menu. The pattern 
will be printed as it appears on your display, so if you want a realistic picture you should switch 
to glass mode in the View menu.



 Tracing

You can place a picture in the background of a pattern so you can trace it. To do that, open the 
"Background" menu and choose one of the "Load From" options. That can take a picture from 
most kinds of picture files (except GIF), from the Windows clipboard, or directly from a scanner. 
If you're scanning, you should use a low DPI, like 100.
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